Debian9安装并保持composer/npm为最新版本

Debian为了保证稳定性,对包版本的态度比较保守,如果想要更新composer和npm为最新版本,一种是通过将/etc/apt/source.list里的stretch源为testing(即测试版)。另一种是在使用稳定版的基础上,通过添加ppa,继续使用apt管理npm;通过直接下载安装composer的官网提供版本,之后使用自带的composer self-update进行更新

Node.js/NPM

一、通过添加ppa,之后使用apt进行管理

1、最新版

先去官网查询最新版的版本号,当前为10.7.0,然后执行以下命令,并将命令中的版本号改为对应的版本号,我目前是10.*版本,所以我的命令是:

curl -sL https://deb.nodesource.com/setup_10.x | sudo -E bash –

sudo apt-get install -y nodejs

2、稳定版

同理,先去官网查询最新的稳定版版本号,当前为8.11.3 LTS,所以我执行的命令是:

curl -sL https://deb.nodesource.com/setup_8.x | sudo -E bash – 

sudo apt-get install -y nodejs

×可选:更换为npm淘宝镜像,保证国内使用速度

sudo npm config set registry http://registry.npm.taobao.org/

更新大版本,需要重新添加ppa为最新,/etc/apt/source.list.d/将自动同步更新

二、通过npm命令更新

接上,使用的命令为

sudo npm install -g npm

Composer

composer和npm不同,不需要额外使用apt进行管理,在需要更新的时候composer self-update即可

php -r “copy(‘https://install.phpcomposer.com/installer’, ‘composer-setup.php’);”

php composer-setup.php

php -r “unlink(‘composer-setup.php’);”

sudo mv composer.phar /usr/local/bin/composer

×可选:更换为Packagist/Composer中国镜像

composer config -g repo.packagist composer https://packagist.phpcomposer.com

发表评论

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据