Debian9安装并保持 composer /npm为最新版本

Debian为了保证稳定性,对包版本的态度比较保守,如果想要更新 composer 和npm为最新版本,可以。在使用稳定版的基础上,通过添加ppa,继续使用apt管理npm;通过直接下载安装 composer 的官网提供版本,之后使用自带的composer self-update进行更新